Nop4.0 - [BUG] Export/Import - Multiple Products with Specification Attribute

2 years ago
Hi all,

Not sure if this is a bug or already being reported. See if you can reproduce it.
I tried this on a brand new setup. This doesnt work on nopcommerce demo site as it is blocked.

STEP 1. Select 2 products with attribute.
Apple MacBook Pro 13-inch
Asus N551JK-XO076H Laptop

STEP 2. Export it.

STEP 3. Import it. Error.

What works,
1. products with NO specification attribute
2. export/import single product with attribute.

Let me know if you guys having this problem. Please share if you found a way to bypass this..

Thanks.
2 years ago
Hi. Thank you, We'll fix this problem soon, please see this work item.
2 years ago
Hello!! I hope there is a fix for this bug!
I made a Stored procedure and registered a few products and it sends this error. Perhaps the problem is in te database. I will try more things and look for more information!
2 years ago
Hello, I investigated this error, and it fixed in 4.10. You can add a simple changes yourself in to ImportSpecificationAttribute method, just add this constraint <|| specificationAttributeManager.IsCaption> into first if statement. Like this and this
2 years ago
Thanks for the speedy work.

Changes made and verified in my environment.
2 years ago
Sergei-k wrote:
Hello, I investigated this error, and it fixed in 4.10. You can add a simple changes yourself in to ImportSpecificationAttribute method, just add this constraint <|| specificationAttributeManager.IsCaption> into first if statement. Like this and this


Hi,

Just wondering if the issue you're talking about here is the same as the issue with importing product attributes & specification attributes here

I can see you've added quite a bit around splitting a large excel import file so was wondering if the issues are different or if you're looking to add additional functionality to the Import/export capability?

Cheers
Garry
1 year ago
Thanks.. It Works