Payment plugin for PayPal BrainTree

1 year ago
Payment plugin for BrainTree (new Drop-in API).

Advantages:
- support any one-page checkout plugins
- create orders after payment (the store's owner sees only paid orders, if customer decides not to pay, the nop order will not be created)
- plugin uses the last API
- plugin supports Capture and Void payments
- plugin supports Recurring Payments (we need testers).

We have another PayPal payment plugins 'PayPal Express Checkout' , 'PayPal Standard Pro' and 'PayPal Plus'.

Not registered version is fully operational. It has only one limitation. You can do 100 payments in unregistered mode. You can try it free.

Link to our site https://www.foxnetsoft.com/braintreedropin.

Compatible with NopCommerce 4.10.

1 year ago
Added support 3D Secure, PayPal, Venmo, Google Pay, Apple Pay
1 year ago
Added support nop 4.20.
7 months ago
Added support nop 4.30.
3 weeks ago
Hi There,

I just tried the NopCommerce Team Braintree plugin and found that there's a UX issue with 3DS. When you complete it, the lightbox disappears and then nothing happens. You have to guess to hit "Next".

Does this work better in your plugin? I don't want my users to be left wondering if it is safe or correct to hit the Next button.

Many thanks in advance,

Giles
3 weeks ago
it solved in my plugin
Try the trial version
https://foxnetsoft.com/content/files/foxnetsoft.braintreedropin.zip
3 weeks ago
Will do. Thank you very much for the swift reply. Sounds like your plugin will be perfect!
3 weeks ago
Hi there,

I've installed your plugin. There were no errors but I AM seeing an error when trying to use it:


There seems to be a Javascript error:
jquery-3.4.1.min.js:2 jQuery.Deferred exception: Cannot read property 'paypal' of undefined TypeError: Cannot read property 'paypal' of undefined
    at new s (https://js.braintreegateway.com/v2/braintree.js:7:23893)
    at Object.i [as create] (https://js.braintreegateway.com/v2/braintree.js:7:30269)
    at HTMLDocument.<anonymous> (<anonymous>:9:34)
    at e (https://shop.bikerbarn.co.uk/lib/jquery/jquery-3.4.1.min.js:2:29453)
    at t (https://shop.bikerbarn.co.uk/lib/jquery/jquery-3.4.1.min.js:2:29755)

I installed by simply unzipping and dropping the correct version into my server then installing. Configuration seemed straightforward.

Many thanks for your assistance,

Giles
3 weeks ago
Does your theme use the native Jquery library from nop kernel?
I didn't understand you. Did you solve this issue?
3 weeks ago
Hi again,

Thanks for getting back to me. My Theme is the NopTemplates Venture Theme (latest version):
https://venture1.nop-templates.com/

It still doesn't work.

Many thanks