Nop 4.1 plugin list error

10 months ago
Hi all,
For the past week I can't access the configuration > Plugins page
This includes :
- my source code dev (local)
- my test site (no source, local)
- all of my production sites

The error I'm getting is as follows:
"
System.Net.WebException: The remote server returned an error: (503) Service Temporarily Unavailable.
   at Nop.Web.Framework.Infrastructure.Extensions.ApplicationBuilderExtensions.<>c.<UseNopExceptionHandler>b__1_1(HttpContext context) in C:\andrei\nopcommerce\sources\src\Presentation\Nop.Web.Framework\Infrastructure\Extensions\ApplicationBuilderExtensions.cs:line 83
   at Microsoft.AspNetCore.Diagnostics.ExceptionHandlerMiddleware.Invoke(HttpContext context)
   at Microsoft.AspNetCore.Diagnostics.ExceptionHandlerMiddleware.Invoke(HttpContext context)
   at Microsoft.AspNetCore.Diagnostics.ExceptionHandlerMiddleware.Invoke(HttpContext context)
info: Microsoft.AspNetCore.StaticFiles.StaticFileMiddleware[6]
"

I think this might be to do with a change on the NopCommerce website itself, when I access the site I first see a screen from 'Cloudflare':

"
Checking your browser before accessing nopcommerce.com.
This process is automatic. Your browser will redirect to your requested content shortly.
Please allow up to 5 seconds…  
DDoS protection by Cloudflare
"

Could this be the cause, if so, how do I solve this?
Regards,
Geoff.
10 months ago
Yes, it is due to Cloudflare blocking access to the feed API.
For more information, please check this thread https://www.nopcommerce.com/boards/topic/74466/version-41-cloudfare-blocks-the-request-to-the-feedmanager-in-nopcommerce-41-making-the-plugin-listi
10 months ago
HI Sanju,
Thanks for the info, this is pain when it comes to using Nop 4.1.
I'm hoping it gets sorted soon.
Geoff.
10 months ago
gbarlow wrote:

Thanks for the info, this is pain when it comes to using Nop 4.1.
I'm hoping it gets sorted soon.
Geoff.


It has been sorted on the newer version of NopCommerce which is 4.2. But I don't think NopCommerce is going to disable DDoS protection any time soon so I suggest you to manually apply the fix for the 4.1.