SAML Single Sign-On (SSO) - miniOrange

SAML Single Sign-On (SSO) - miniOrange
4.9 7
miniOrange Single Sign On (SSO) plugin allows SSO with Azure AD, Azure AD B2C, Keycloak, ADFS, Okta, Shibboleth, Salesforce, GSuite or Google Apps, Office 365, OpenAM and all SAML 2.0 capable Identity Providers into your nopCommerce store.
2023-08-20T04:45:13.3954204Z
Free
Get extension (161 Downloads)
Supported versions: 4.30, 4.40, 4.50
Created: September 01,2021
Last updated: August 12,2022
Description
miniOrange Single Sign On SSO – Login plugin allows SSO with Azure AD, Azure AD B2C, Keycloak, ADFS, Okta, Shibboleth, Salesforce, GSuite / Google Apps, Office 365, SimpleSAMLphp, OpenAM, Centrify, Ping, RSA, IBM, Oracle, OneLogin, Bitium, WSO2, NetIQ, ClassLink, FusionAuth, Absorb LMS and all SAML 2.0 capable Identity Providers into your nopCommerce store.

Installation instructions:

  1. Download the plugin archive.
  2. Extract the downloaded archive. From the extracted zip, select the plugin zip to upload as per your nopCommerce store version
  3. Go to admin area > configuration > local plugins.
  4. Upload the plugin archive using the "Upload plugin or theme" plugin.
  5. Scroll down through the list of plugins to find a miniOrange SAML SSO plugin. And click on the "Install" button to install the plugin.
  6. Once the plugin is installed please go to the How to Setup tab in the plugin which will guide you with required steps for Single Sign-On (SSO) configuration with your identity provider.
  7. Alternatively, you can follow this guide which will help you with plugin setup.

If you require any Single Sign On (SSO) application or need any help with installing this plugin, please feel free to email us at [email protected] or Contact us.

Plugin Features

  • miniOrange SAML Single Sign On supports Single Sign-On SSO with any 3rd party SAML supported Identity Providers like ADFS, Azure AD, Azure AD B2C, Keycloak, Okta, Salesforce, GSuite / Google Apps, O365, Shibboleth, SimpleSAMLphp, OpenAM, Centrify, Ping, RSA, IBM, Oracle, OneLogin, Bitium, WSO2, NetIQ, ClassLink, FusionAuth, Absorb LMS etc to login into your nopCommerce store.
  • Auto Create Users : Users will be auto-created in nopCommerce after SAML Single Sign-On(SSO) using our Single Sign On ( SAML SSO) plugin.
  • Login Links : Use SAML Login link to easily integrate the SAML SSO with your nopCommerce store.
  • Attribute Mapping :Map user claims sent by your SAML compliant Identity Provider with the Username and Email of your nopCommerce users.
  • Role Mapping : Assign default nopCommerce role to SAML Single Sign-On(SSO) users on auto registration during SAML Single Sign On (SSO).
  • Multistore SSO Support : Allows SSO on separate substores or multiple substores. Configure the IDP for all your stores in a network.

LIST OF SUPPORTED IDPS :

Reviews
valeriemca 5/6/2022 2:07 PM
Works great with our version but need further update!
Hello,
I had my developer test your plugin on UAT for our current store version and it works well. We are migrating completely to v4.50 by the mid of this month, will you be able to provide a plugin update soon, any ETA ??
Was this review helpful? Yes0 / No0
A manager responded to this review
Hi @valeriemca,

Good to know that our plugin is helping you with integrating the SSO in your nopCommerce store.

We've just a release for the plugin which is compatible with nopCommerce v4.3, v4.4 and v4.5.

You can just give it try for your nopCommerce v4.5 store by downloading from store. You can also follow the steps mentioned on the below setup guide page: https://plugins.miniorange.com/nopcommerce-saml-single-sign-on-sso

If you need any help or assistance with setup or configurations, then please feel free to reach out to us on the above mentioned support email and we'll reach out back to you in no time!

Thanks,
miniOrange Team.
NilsBioch 3/28/2022 1:47 AM
V4.50 support?
First of good plugin, I do have a question though, are you still working on 4.50 support? If so do you have a estimated release date?
Was this review helpful? Yes2 / No0
togreiseren 2/6/2022 2:23 PM
4.50 support
Hi, great plugin. We have 4.50 an when i upload the plugin it says "This plugin doesn't support the current version - 4.50". Can I fix this in the plugin my self?
Was this review helpful? Yes1 / No0
A manager responded to this review
Hi @togreiseren,

Thanks for adding the review and it's great to know that you liked our plugin!
The miniorange's current plugin listed here does not have the support for nopCommerce v4.50.
Our team is currently working on the  plugin which will be fully compatible with all nopCommerce 4.*  versions.
You can expect the release for the same by the end of the February 2022.
Once the release is done we'll update you here.
For now please let us know if you've any other questions, we'll be happy to help.

Thanks,
miniOrange team.
katlyn2120 2/3/2022 4:16 AM
Works Flawlessly! User Friendly and a Great Product!
Hey,
I have successfully integrated your SAML SSO plugin on my test nopCommerce store with Okta. I was wondering if you could help me in testing the Premium features of the plugin, please ?
Thanks,
Was this review helpful? Yes0 / No0
A manager responded to this review
Hi @katlyn2120,

Thanks for adding the review and it's really good to know that our plugin helping you with accomplishing your SSO requirements!
Yes, definitely we can provide you with a trial version for testing the premium features listed in the plugin.

You can raise a trial request using the support email or the contact us form mentioned in the plugin description above.

If you've any other queries then please feel free to let us know.

Thanks,
miniOrange team.
skyloRen 1/18/2022 4:37 AM
Good Plugin
The plugin works great with many different SSO.
Was this review helpful? Yes0 / No0
raymond.pacayra 1/5/2022 12:51 AM
miniOrange (SSO) plugin for Okta
I've been using the miniOrange (SSO) plugin for integrating to Okta identity management. Installation is a Breeze in a nopCommerce admin portal. Configuration requires a bit of technical skill on the subject matter. Support from the developer is top-notch. The support team helped me out in troubleshooting my integration which contributed to the success of my project.
Was this review helpful? Yes1 / No0
mtas 9/6/2021 2:09 AM
Support 4.40
Will you support version 4.40?
Was this review helpful? Yes0 / No0
A manager responded to this review
Hi @mtas,

Thanks for adding the review.
Yes, our team is currently working on the  plugin which will be fully compatible with nopCommerce v4.40 as well.
You can expect the release for the same in this or the upcoming week.
Once the release is done we'll update you here.
For now please let us know if you've any other questions, we'll be happy to help.

Thanks,
miniOrange team.