SSL Config - http is still available

7 months ago
Hi

I'm still in the process of setting up my store. I've just got my ssl cert installed and I can now browse via HTTPS and the cert is valid etc. However I can still browse to HTTP and it doesn't redirect. I've read some Microsoft docs and they suggest adding "app.UseHttpsRedirection();"

Is this the right thing to do with NopCommerce? I have enabled the SSL option in the admin panel.

Thanks
7 months ago
What version are you using ?
Here are a couple of posts about it
https://www.nopcommerce.com/en/boards/topic/83124/hosting-as-https-only
I rember another when
7 months ago
Thanks for your reply!

I'm using v4.3

Just read through the links and I've tried most besides the webconfig change. Simply by ticking the use SSL in admin settings doesn't work.

Do you know what I should add in the web config?
7 months ago
What kind of server setup are you running. If IIS you can force ssl on the site via the SSL settings in IIS as long as the cert is installed and valid. Or just try removing the http binding on the site and only bind via https.
7 months ago
I am using IIS, however I am using a shared hosting environment. This means I don't have access to the IIS config to edit the bindings etc.
7 months ago
see here akz_gohil - I think you can put the re-write settings into your web.config file (which you should have access)

https://www.nopcommerce.com/en/boards/topic/81854/force-ssl-option-missing-in-nop-43-

Cheers
Jon

[email protected] wrote:
I am using IIS, however I am using a shared hosting environment. This means I don't have access to the IIS config to edit the bindings etc.