Finalmente NopCommerce 2.3 su Aruba !!!

7 years ago
Ciao ragazzi ma nessuno ha reso disponibile alla community una versione stabile di NopCommerce in italiano con le modifiche su partitaIva, fattura ed integrazione con i sistemi di pagamento italiani?
7 years ago
Attualmente no.
Noi l'abbiamo fatto per un cliente italiano.
7 years ago
biapar wrote:
Attualmente no.
Noi l'abbiamo fatto per un cliente italiano.

Riesci a darmi qualche dritta su come tradurlo e gestire la partita IVA ed integrare altri sistemi di pagamento?
7 years ago
I sistemi di pagamento vanno sviluppati ad hoc se non sono disponibili. Nella serie 2.x sono tipo plugin, mentre nella 1.9 comporta anche la ricompilazione di alcune parti core.
Per la traduzione importi il file xml presente sul sito ufficiale area download.
Per il resto vanno modificate un po' di cose e classi.
7 years ago
biapar wrote:
I sistemi di pagamento vanno sviluppati ad hoc se non sono disponibili. Nella serie 2.x sono tipo plugin, mentre nella 1.9 comporta anche la ricompilazione di alcune parti core.
Per la traduzione importi il file xml presente sul sito ufficiale area download.
Per il resto vanno modificate un po' di cose e classi.


Sinceramente è la prima volta che utilizzo questo sistema di ecommerce. Tu cosa mi consigli di fare? Utilizzare il metodo di installazione fornito da Aruba oppure scaricare l'ultima versione dal sito e fare il deploy dei compilati? Inoltre mi sai dare qualche dritta sui plugin?
7 years ago
Salve ho un problema di installazione su OPCOMMERCE aruba, se installo la versione wizard di aruba 1.60 si installa perfettamente, io dovrei installare la versione 2.65 e quindi ho eseguito i seguenti passi

1) scaricato la versione nosource
2) via ftp trasferita
3) abilitato lettura/scrittura cartelle
4) abilitato framework 4.0
ma non mi parte l'installazione cosa sbaglio
7 years ago
Hai qualche dettaglio sull'errore in più?
7 years ago
Buongiorno, probabilmente potrebbe essere un problema di connessione con il database... Io ho installato su Aruba la 1.9 in italiano perchè completa delle condizioni obbligatorie sulle privacy e altro. Le successive versioni, anche se dotate di ulteriori opzioni, non credo possano interessarmi molto.  Se eventualmente ti interessa posso inviartela x mail. www.web-ricambi.it PS. ci sto ancora lavorando....
7 years ago
10021 wrote:
Buongiorno, probabilmente potrebbe essere un problema di connessione con il database... Io ho installato su Aruba la 1.9 in italiano perchè completa delle condizioni obbligatorie sulle privacy e altro. Le successive versioni, anche se dotate di ulteriori opzioni, non credo possano interessarmi molto.  Se eventualmente ti interessa posso inviartela x mail. www.web-ricambi.it PS. ci sto ancora lavorando....


Ciao,

quindi come possiamo aiutarti?
PS: abbiamo introdotto anche le condizioni obb e privacy anche per la versione 2.x
7 years ago
atlogica wrote:
Salve ho un problema di installazione su OPCOMMERCE aruba, se installo la versione wizard di aruba 1.60 si installa perfettamente, io dovrei installare la versione 2.65 e quindi ho eseguito i seguenti passi

1) scaricato la versione nosource
2) via ftp trasferita
3) abilitato lettura/scrittura cartelle
4) abilitato framework 4.0
ma non mi parte l'installazione cosa sbaglio


Salve,
anche io stavo avendo problemi con l'installazione di NOP 2.65 su Aruba, in particolare nel passaggio dalla versione 2.4 (installata di default) alla versione 2.65 (l'ultima supportata per il loro ambiente, a quanto mi risulti al momento).

I passi sono gli stessi che ho seguito io, ma in aggiunta ho fatto quanto segue:

5) ho cambiato la modalità ASP da 4.0 a 3.5 e applicato, quindi ricambiato da 3.5 a 4.0 integrated mode, e riapplicato

questo sembra forzare il riavvio del server che potrebbe avere tenuto in memoria qualcosa dalla precedente "sessione".

6) ho commentato queste righe dal file Web.config nella radice del sito:
<staticContent>
      <clientCache cacheControlMode="UseMaxAge" cacheControlMaxAge="1.00:00:00" />
    </staticContent>
    <urlCompression doStaticCompression="true" doDynamicCompression="true" />

facendole diventare dunque:
<!--
    <staticContent>
      <clientCache cacheControlMode="UseMaxAge" cacheControlMaxAge="1.00:00:00" />
    </staticContent>
    <urlCompression doStaticCompression="true" doDynamicCompression="true" />
-->

(non so per quale motivo mi desse errore, per il momento le mie installazioni possono sopravvivere anche senza compressione e senza cache)

Infine, nel caso servisse, questa è la stringa che uso per la connessione al server MSSql su Aruba:

Data Source=[IP_SERVER_DB_ARUBA];Integrated Security=False;User ID=[NOME_DB_ARUBA];Password=[PASSWORD_DB_ARUBA];MultipleActiveResultSets=True;Connect Timeout=0;Encrypt=False;Packet Size=4096


Dove ovviamente i valori tra parentesi quadre vanno rimpiazzati di volta in volta a seconda del sito, togliendo anche le parentesi stesse.

Spero che sia d'aiuto, e se qualcuno sa il motivo del problema con il file Web.config e come correggerlo mi piacerebbe sapere la soluzione corretta.